Troubleshoot OS Deployment
The following is a description of the common troubleshooting tools available for CapaInstaller OS Deployment. Some of the common pitfalls are listed with suggestions for solutions.
Log files
Section titled “Log files”| Log file | Description |
|---|---|
X:\Logs\OSDBootStrap.log |
Written in WinPE when the OSD client starts. Contains information about the startup, network and connection to the OS Deployment server. |
X:\Logs\OSDClient.log |
Written in WinPE by the OSD client. Contains information about the selections and every step of the deployment. |
X:\Windows\Logs\Dism\dism.log |
Written in WinPE when the image is applied and drivers are added. |
<ScriptName>.log and CapaInstaller BaseAgent.log |
Written in WinPE to X:\Program Files\CapaInstaller\Client\Logs when OSD scripts and the CapaInstaller agent run. |
C:\osdlogs |
Just before the client reboots, the OSD client copies the log files from X:\Logs to the osdlogs folder on the drive that Windows was deployed to. |
| Client log folder | If the OS Deployment server has access to it, the OSD client also uploads its log files to the server during the deployment. You set the folder in the console options under OS Deployment → OSD Client installation logs → Client log folder. The folder is located on the Back-end server. |
| OSDLoader.log and OSDGUI.log | Written to X:\Logs by the legacy OSD client (OSDLoader and OSDGUI) that legacy BIOS clients use unless Use OSDClient for Legacy clients is selected in the console options. |
| Console log | Contains information about all operations conducted from the CapaInstaller console. See CapaInstaller log files. |
| SETUPAPI.log | This log contains valuable information about the MiniSetup process and can often help to locate hardware-specific problems that occur during the MiniSetup process. |
In WinPE, you can open the OSD client, bootstrap, DISM and base agent logs from the OSD client’s menu.
Common problems
Section titled “Common problems”| Symptom | Possible cause |
| Unable to boot PXE client | Make sure the client BIOS is set up correctly. Some systems require that the boot ROM BIOS is enabled to allow a PXE boot. |
| Unable to load boot image | Make sure that DHCP options are set up to point to the cipcc.0 file and that the cipcc.0 settings for priorities are correct for the network. Be aware that if the PXCONFIG.EXE program has the cipcc.0 file open, no clients are able to boot using this file. When the file is closed, clients can use it again. |
| Unable to load WinPE | Make sure the boot image (wim) is not mounted using imagex.exe. This will always result in an error and the following message: Status: 0xc000000f Info: The boot selection failed because a required device is inaccessible. |
| Unable to locate a C: drive | This error occurs if WinPE has no drivers available for the storage type in the client. To add such drivers to WinPE, refer to the help topic “Adding drivers”. Always remember to use Vista-compatible drivers. |
| The client freezes with a black screen before running MiniSetup. | The client is unable to boot using the HAL used by the image. Please build the image using the correct HAL driver. Some client platforms require a specific HAL to function, CapaInstaller OS Deployment can support these but the images must be tailored specifically to support this. |
| The client keeps rebooting after the image is applied, or stops with BSOD error code 7B | This error occurs when the image does not contain the required storage manager drivers for the client. Refer to the help topic “Adding support to additional Mass Storage devices” to solve this problem. |