Frontend Server Disk Space Check
The PerformanceGuard frontend server automatically checks if there is enough disk space on the computer that runs the frontend server.
The frontend server will automatically stop accepting data from PerformanceGuard agents if there is less than 3000 MB (about 3 GB) free disk space on the drive where the frontend server stores agent data. It checks again every 10 seconds, and automatically resumes accepting data from agents as soon as there is 3000 MB or more free disk space.
Technically, when the frontend server stops accepting data from agents, the PerformanceGuard Frontend Server service itself does not stop, but it stops listening on the port that agents use to deliver data (by default TCP port 4001, see Installation).
How will I know if a frontend server stops accepting agent data?
Section titled “How will I know if a frontend server stops accepting agent data?”There are several indications.
Frontend server log
Section titled “Frontend server log”PerformanceGuard administrators can see it in the frontend server log file, available on the Log Files tab (see View Log Files) of the PerformanceGuard web interface or directly under [PerformanceGuard installation folder]\collector\logs.
-
When the frontend server stops accepting data from agents, a warning like this is logged, with the number of megabytes left:
Not enough disk space, only [number] MB left, waiting -
When the frontend server resumes accepting data from agents, this warning is logged:
Disk no longer full, continuing
System Status reports WARNING or FAILURE
Section titled “System Status reports WARNING or FAILURE”PerformanceGuard administrators can see it in the PerformanceGuard web interface: When the frontend server stops accepting data from agents, the Agents Online status on the System Status tab (ADMINISTRATION > Status > System Status) changes to WARNING and then to FAILURE, because agents no longer deliver data. See System Status.
Use Server Surveillance Tool to get automatic notifications
Section titled “Use Server Surveillance Tool to get automatic notifications”PerformanceGuard has a separate downloadable tool for monitoring the status of the PerformanceGuard system and alerting you by e-mail if something is wrong. The tool can thus automatically notify you if a frontend server stops accepting data from agents. This requires that you download, configure and run the tool. The tool can also write PerformanceGuard status messages in the Windows event log.
Poll the system status automatically
Section titled “Poll the system status automatically”You can monitor the status of your PerformanceGuard system from another system, and get notified if the status changes. See Automatically Poll System Status from External System in System Status.