Skip to content

System Status

If you select ADMINISTRATION > Status > System Status, you can view the general health of your PerformanceGuard system through status information about system jobs and resources. A number of system checks are performed every time you access the page.

This tab shows the status of the PerformanceGuard subsystems.

Subsystem Description
Database Connection Tells you whether the PerformanceGuard web interface is able to connect to the database.
Database Storage Overall status of SQL Server file group. You can view more detailed information about this on the Database Storage tab (see the following).
Scheduled Jobs Overall status of scheduled jobs. You can view more detailed information about this on the Scheduled Jobs tab (see the following).
Agents Online Tells you whether any PerformanceGuard agents are currently delivering data to PerformanceGuard. The status is OK if the latest agent delivery is less than 3 agent delivery intervals old, WARNING if it’s less than 10 intervals old, and FAILURE if it’s older.
Disk Space Overall status of local disk space. You can view more detailed information about this on the Disk Space tab (see the following).
Log files Overall status of log file growth. This status is never worse than WARNING. You can view more detailed information about this on the Log Files tab (see the following).
Frontend Servers Status of your PerformanceGuard solution’s frontend servers.
Email Delivery Status of automated delivery of notifications and reports.
Auto joined port spammers found Yes if PerformanceGuard has automatically joined the ports of servers that use many dynamic ports. See Join Server Ports to Get Targeted Information.
Status Description
OK The subsystem is working correctly.
NA Status for the subsystem isn’t available.
WARNING The subsystem is either close to a FAILURE, or the execution time of a task is getting close to a time limit.
FAILURE The subsystem isn’t working correctly. Either the subsystem itself has failed, or the subsystem has failed to complete its task within a required time limit.

The time limit used for evaluating WARNING and FAILURE is set differently on the individual subsystems.

This tab shows the status of your PerformanceGuard solution’s frontend servers: Whether they are online, the PerformanceGuard version they are running, whether they’re enabled, their priority, and the number of PerformanceGuard agents that are online on them. Click the name of a frontend server to view details about it.

The tab also lists the most recent requests from the backend server to the frontend servers. Click the name of a request to view details.

For more information about frontend servers, their priorities, etc., see also Manage Frontend Servers.

PerformanceGuard runs a number of batch jobs in the background. Most of those jobs aggregate data (see Aggregation of Data) and delete old performance data, but there are also jobs that generate alerts, calculate KPI (Key Performance Indicator) and SLA (Service Level Agreement) values, etc. Some of the jobs are SQL Server jobs scheduled by the SQL Server Agent.
Examples of scheduled jobs:

  • Citrix Data Aggregation
  • SLA Calculation

On the Scheduled Jobs tab you can view information about each scheduled job: the job interval (that is how often the job is supposed to run), when it was last started, last active and last completed, how long it took, and whether it’s enabled. You can also view the status of each job. The status is based on the following criteria:

Status Description
OK The job runs and completes as expected.
WARNING The job hasn’t been active for more than 2 × the job interval. Example: With a job interval of 60 seconds, status changes to WARNING if the job hasn’t been active for more than 2 minutes.
FAILURE The job reported an error. Alternatively, the job hasn’t completed for more than 5 × the job interval, or it has been running without completing for more than 10 × the job interval. Example: With a job interval of 60 seconds, status changes to FAILURE if the job hasn’t completed for more than 5 minutes (or 10 minutes if the job is still running).
NA The job is disabled, or it has no status yet.

This tab shows the total and available disk space for each file group in the PerformanceGuard SQL Server database.

If available disk space is less than 5%, the System Status tab (see the previous) will report a WARNING status for the Database Storage subsystem. If available disk space is less than 1%, the status will be FAILURE.

The Disk Space tab shows the available disk space on the server on which the PerformanceGuard Web Server service runs.

For each physical drive the total and available disk space is listed. By default, if available disk space is less than 5%, status of the drive will be WARNING. If available disk space is less than 2%, status of the drive will be FAILURE.

This tab lists the files in the log folders that PerformanceGuard monitors, with the size of each file in kilobytes and how much it has grown per hour. Click the name of a file to open it. See View Log Files.

PerformanceGuard can monitor log file growth and mark a log file with a WARNING or FAILURE status if its growth rate is higher than a specified value. The overall Log files status on the System Status tab is never worse than WARNING.

To specify which log file folders you want to monitor, select ADMINISTRATION > Setup > Parameters, select the Display tab, scroll down to the Directories section, and specify the path to the required log file folders in the Monitor Log Folders field. By default, PerformanceGuard monitors the display\logs, collector\logs and notification\logs folders in the PerformanceGuard installation folder.

If you want to specify multiple folders, use a comma to separate the paths.

On this tab you can view information about any report e-mails (see Manage Custom Reports) that are waiting to be sent.

If the tab shows that status is not OK, it is typically due to problems with the mail server that PerformanceGuard uses (see Manage SMTP Notification Service). You can check the PerformanceGuard mail server configuration by selecting ADMINISTRATION > Setup > SMTP. If the PerformanceGuard mail server configuration is correct, contact the administrator of the mail server for information about the status of the mail server.

This tab provides detailed information about deletion jobs, including how long data is stored in each table in the database. If a scheduled deletion job fails, this information lets you identify which database table is causing the problem.

Column Description
Label A unique label name for each delete action.
Table The name of the database table that data is deleted from.
Parameter The name of the parameter in the STATUS table that controls how long data is kept in the database.
Elapsed (s) The time that it took to execute the last successfully completed delete action.
Delete point The next time stamp to delete. This should be the time stamp of the oldest data in the table.

On this tab you can view the backend database version history with time stamp and version information for each upgrade. The database is typically upgraded when you upgrade your PerformanceGuard solution by installing a new version. See Upgrade Version 8.0 or Newer to Latest Version.

  • The Status column can indicate either started (ongoing upgrade), applied (successful upgrade) or failed.
  • In the Rollup column, Yes indicates that the upgrade version includes previous versions so that it’s possible to subsequently apply a previous version if required.
  • The Message column is typically empty, but may contain problem-finding information about failed upgrades.

Automatically Poll System Status from External System

Section titled “Automatically Poll System Status from External System”

It’s possible to poll the status of your PerformanceGuard system from another system. This way you can automatically monitor the status of your PerformanceGuard system.

It works like this: By requesting certain URLs from a standard HTTP client, you’ll receive a simple JSON plain text version of the PerformanceGuard system’s status.

All URLs require basic authentication using standard PerformanceGuard user credentials.

Status values can be either OK, NA (that is status not available), WARNING or FAILURE. Your automatic monitoring job should request the system status page and check for the words WARNING or FAILURE.

Here we have used a Chrome browser to ask for the overall PerformanceGuard system status by requesting …/rest/system/status:
JSON response from the system status URL showing systemStatus OK

Here we have asked for the status of each subsystem by requesting …/rest/system/status/subsystems:
JSON response listing each subsystem with its status and description

Here we have asked for frontend server status by requesting …/rest/system/frontends:
JSON response listing the frontend servers and whether they are online

It’s the PerformanceGuard Web Server service that provides the data that you can poll. If the service uses the default ports 80 and 81, you don’t need to specify a port number in your request, but if the service uses a different port number, you must specify that port number in your request.